Mitsubishi convergence IC's used in the differant models

696 posts / 0 new
Last post
Larry Dillon
Larry Dillon's picture
a sqaure wave is what you re

a sqaure wave is what you re suppose to get going to the transformer primary. pprhaps check the diodes at the other end of the trnsformer. it looks like a transformer return problem.

Sean_Fahey
Sean_Fahey's picture
Larry,

Larry,

OK. On the Model 65311, I did get the diagnostic trouble code by pressing the "Menu" and "Input" Buttons together. The code is 23. So, what do I need to check now? I'm ready with all instruments ready to go...

Thanks again!

Sean_Fahey
Sean_Fahey's picture
Larry,

Larry,

I was also wondering if you might have a Schmatic of this model that I could reference off of?

THanks again for your help!

Sean
fahey.s@comcast.net

young one
young one's picture
Boy am I glad I stumbled

Boy am I glad I stumbled across this site. I am having a problem with my VS-60719 I turn it on and then after about 5 seconds it turns back off. It is giving a code 2 3. I removed the back panel and when I powered on all the tubes were powering up then about 5 seconds later I heard a click noise and they cut back off. I have taken out both boards from the chasis so far I have noticed R5k43 has a black char look on top, Also D522(-24side) has a black coloration on the board on the end closest to R522, D972 has a black discoloration on the board around both legs, L963 has the same black discoloration under it. I have removed the convergence IC which is labeled STK393-110 I ony see the one. All the fuses look intact and not blown.

My question is this what should I do? Is the black discoloration normal over time on the board or is this a sign that I should replace these componets?

Thanks in advance for the help also my email address is tann3100@yahoo.com

Thanks
Brian

Italnstaln215
Italnstaln215's picture
Larry, I have a Mitsubishi WS

Larry, I have a Mitsubishi WS-A65. Last weekend it began to lose its color and then intermitenly flicker, then the screen went black all together. At this point when I turn it on all I get is a black screen with no sound. The power light is lit solid and I can hear it turn on but thats all I get, please help. This TV is the center of my family room and were lost without it.

Thank you in advance.

XboX Hacker
XboX Hacker's picture
Hi everyone, i have a issue

Hi everyone, i have a issue with my Mitsu, i want to know if i am on the right track!

I have a WS-73903
CHASSIS: VZ6-V15
This is the Convergence chip for it: STK392-040

OK, now the problem.... One day i turned it on and i have sound but no
image, I can see the "input 1" in the top corner..and its convergence
is off. So being a arcade tech, and having worked on monitors, i was
not afraid to jump in and poke around.

I removed the "Conv-Gene" board form the chassis. Without the
Conv-Gene, i turned on the TV and i now get a picture and sound. The
picture is way out of convergence! I can not adjust the convergence
without the the generator. So i put the Conv-Gene board back in and
turn the TV back on....now i am back to the original problem...no
picture except for the "input 1" in the top corner.

So my question is... is it a bad Con-Gene board or bad Convergence ICs..or both...or what???

Thank You!!!!

 

billman311@aol DOT com

Hughesjerry
Hughesjerry's picture
I have a Mits. Ws-65511 and I

I have a Mits. Ws-65511 and I tried replacing(sodering was not easy) the IC chip as noted above and it still won't power up. It comes on for a second and it shuts off. Do you know where I can purchase the entire board that has this IC? I figure if I replace the entire thing I should have it right. Thanks..
hughesjerry69@yahoo.com

Larry Dillon
Larry Dillon's picture
ptscorp.com will rebuild

ptscorp.com will rebuild THESE boArds long s you did not harm it or ruin it ehn roldeing.

King_Ped
King_Ped's picture
Larry,

Larry,
I have a Mitsubishi WS-55907 model, it will not power up. I can hear the click sound, but it just won't come on. WHat I can do to get this fix. My email is soukanh@yahoo.com. Can I get a copy of the service manual?

WoogieBoogie
WoogieBoogie's picture
Hey Larry, I have a

Hey Larry, I have a Mitsubishi WS-65903. Recently the Blue convergence has gone way out of whack and I have gotten the bowtie and blue outline effect. Do you have the service manual for this set? Are the Convergence IC's the problem? Any help would be great. Thanks a lot.

wes007
wes007's picture
I have a WS-55807 mits that

I have a WS-55807 mits that will not turn on . Would you email me a service manual for this? I need all the help i can get thanks stacewes@jvlnet.com

texflats
texflats's picture
I am working on a WS-73907.

I am working on a WS-73907. The set would not power up and displayed the 22 error code. I pulled out the board and checked the fuses and sure enough F90A4 was blown. I replaced that with a 5a glass fuse. Now the convergence is way off. I will order the STK392-570 from electronic repair kits. I see mentioned in a previous that some of the resistors might need to be checked as well. Do you know which ones that would be?

WoogieBoogie
WoogieBoogie's picture
WoogieBoogie said: Hey Larry,

WoogieBoogie said: Hey Larry, I have a Mitsubishi WS-65903. Recently the Blue convergence has gone way out of whack and I have gotten the bowtie and blue outline effect. Do you have the service manual for this set? Are the Convergence IC's the problem? Any help would be great. Thanks a lot.

I purchased the technical training manual for my set, WS-65903, it has the schematics and setting up procedures but it doesnt have the service manual. If anyone has the service manual I would really appreciate it. I took the chipset out with the heatsink and 2 IC's, two of the pins were loose and the connecting pads were loose on three pins. I also found three resistors that look burnt. The board is burnt around them too. Any problems that are a result of burnt resistors? What kind of resistors  should I get to replace them? Pictures attached of resistors and board. Also, when I replace the heatsink and two new IC's what order should I do it in? ie: Solder two IC's, then screw in heatsink while inside the TV, then aplly the thermal paste. Thanks a lot for any help.

 

Burnt Resistor 1

Burnt Resistor 2

lazypop
lazypop's picture
My Mits WS-65713 started

My Mits WS-65713 started flashing the green LED light right after I built a HTPC and was hooking it all up. I plugged in my 65" and all I got was the flashing light on the front. After reading these comments I removed the DM board and sure enough the 16v 1000 micro Farad caps were swollen. I actually got excited after seeing this. I pulled the caps out ( the solder wick works best ) and replaced them ( long legs on radial lead components denote positive )with new ones. I cleaned all the dust from the other boards and put it all back together. Low and behold it works. Mitsubishi should be ashamed for using such poor grade capacitors if this is the case for so many failures. That little DM board is not worth $600-$1000. Years ago Mitsubishi was the Lexus of big screens but not anymore. I'm probably going to get a laser DLP set a few months after they come to market. Thanks

King_Ped
King_Ped's picture
Dave51 said: My Mits WS-65713

Dave51 said: My Mits WS-65713 started flashing the green LED light right after I built a HTPC and was hooking it all up. I plugged in my 65" and all I got was the flashing light on the front. After reading these comments I removed the DM board and sure enough the 16v 1000 micro Farad caps were swollen. I actually got excited after seeing this. I pulled the caps out ( the solder wick works best ) and replaced them ( long legs on radial lead components denote positive )with new ones. I cleaned all the dust from the other boards and put it all back together. Low and behold it works. Mitsubishi should be ashamed for using such poor grade capacitors if this is the case for so many failures. That little DM board is not worth $600-$1000. Years ago Mitsubishi was the Lexus of big screens but not anymore. I'm probably going to get a laser DLP set a few months after they come to market. Thanks

Do you have any picture to show?

lazypop
lazypop's picture
 There are pictures attached

 There are pictures attached to comments in the threads concerning Mitsubishi TV problems with turning on. Actually there are several references to the same problem with the capacitors on the DM board. I referenced the pictures of the capacitor problems in order to fix my problem.

shanestro
shanestro's picture
Hey whats up? I see you are

Hey whats up? I see you are THE MAN on these mitsubishi tvs. I have a ws 73903 and i am havin a prob with the blue convergence its all crazy and wont adjust. I install home theaters in florida and lets just say I got this tv really cheap. It worked for a few weeks then the blue went crazy can you tell me what parts I need to install? thank you. shanestro.

gsmith
gsmith's picture
hey larry i have model 65819.

hey larry i have model 65819. at 1st it was my convergence and upon taking out my middle board i bumped up agaist the heat sink and the tv went off and i got the blinking light of death. i then replaced the ic's with the sanyo ic's and my pico fuse 04 and 05. still nothing! then i changed the 4 capacitors on the board. still nothing! i'm stumped. any help is greatly appreciated!!! lexg3@yahoo.com thanx larry

WoogieBoogie
WoogieBoogie's picture
I would greatly appreciate it

I would greatly appreciate it if anyone can tell me what those resistors are and where I can buy them from the post I made above. I believe they are 5.6 ohm 5% tolerance but am not sure on wattage. Thanks.

gsmith
gsmith's picture
hey larry my pico 5 fuse had

hey larry my pico 5 fuse had to be resoldered. got my tv on and now no picture. the tubes in the back are not firing up. any suggestions?

falcon1
falcon1's picture
I just had the red

I just had the red convergence problem pop up on my WT 46807. When the TV is cold it does not show up but when it's been on for a few minutes it starts until it gets very bad. It cannot be adjusted. The other day I slapped the side of the tv and the problem disappeared for a few minutes but returned. I was thinking it might be a broken solder terminal. I found the Sanyo ICs but can't find the pico fuses. Where can I find them?

Mike 55809
Mike 55809's picture
I was told that my

I was told that my convergence circuits were going bad, casusing a convex, bent picture when first turned on.

Are these convergence circuits easy to replace? Or are they part of a larger circuit board?

my model is WS-55809.

Thanks
mkobler@comcast.net

falcon1
falcon1's picture
gsmith said:

gsmith said:

Suburban Electronics on ebay.

Thanks.

gsmith
gsmith's picture
mike if u have a steady hand

mike if u have a steady hand and can solder a lil bit u can do it

HenryV
HenryV's picture
Larry,

Larry,
I have a Mitsubishi 65907 and the same problem as a lot of other people. The power goes on and immediately off. I checked the sequence and it's 2-1 X-Ray Protect Circuit. How do I fix it myself or do I have to call a tech. Is this TV worth fixing this problem?

Mike 55809
Mike 55809's picture
Hi Larry,

Hi Larry,

I have the WS-55809 and with the same convergence problems that i read in other similar postings.

My picture is bent and blurred for 30 seconds before it snaps into a good picture.

I understand that i must change the stks and i have the correct model number.

However , where are the stks located. In the back opening, I have before me three circuit boards.

Are they located in the center?

Do you have a picture of the circuit?

Thanks Mike55809

CPhillips
CPhillips's picture
Hi - I have a Mitsubishi Big

Hi - I have a Mitsubishi Big Screen , Model WS-55411, I cut it on , the green light comes on like it is going to come on , and then 2 seconds later it clics off - NO PICT - nothing. HELP???

falcon1
falcon1's picture
I took my WT 46807 apart and

I took my WT 46807 apart and found cracked solder joints on one of the IC convergence chips. A bit of resoldering and it's a good as new. Thanks for the info.

CPhillips
CPhillips's picture
falcon1 can you recommend

falcon1 can you recommend anyone who can do these repairs? Would something like be expensive to fix??

falcon1
falcon1's picture
I did the repair myself but I

I did the repair myself but I assume anyone with some good soldering skills and mechanical ability should be able to do it. Taking all the harnesses off and removing the boards was more intimidating than the actual repair. You also have to know the location of the ICs and inspect the solder joints with a magnifying glass. Have you done the slap test to your TV to see if it is a loose connection? That's how I figured that it was a loose connection. As for the cost, it only cost $2 for a small roll of solder and my time. If you hire someone it will cost you between $350 and $500 according to the posts I've read here. Your problem seems to be different. Sounds like a power supply problem.

Pages

 

Connect With Techlore