Mitsubishi WS65611 Volume Control Problems

11 posts / 0 new
Last post
MEB23
MEB23's picture
Mitsubishi WS65611 Volume Control Problems

I have a Mitsubishi 65 inch that the volume stopped working on the remote and the front panel.  I had the "Blinking light of Death" and Convergence problems 2 years ago.  I fixed both of them thanks to tvrepairkits.com.

The Volume bar appears on the Screen and won't go away or change. I have already tried the reset button.  I have read on a different thread that this might be the DM module.

Can someone send me some information (i.e. Sevice maunal, instructions) on how to fix this problem?

Any help would be much appreciated.

 

Thanks

Kato
Kato's picture
Hey I hope you didn't ditch

Hey I hope you didn't ditch the unit yet.

If not try powering up the tv, once you hear it kick on, on your original remote enter "menu 1,2,3" this will take you to the "Factory reset" settings. This is different from the reset on the front. Post your results. I hope this does it for ya it did for mine.

I was suggested to replace all kinds of parts. The tv was fine right before the new lamp went in then the green light started.

 

Kato

MEB23
MEB23's picture
Kato,

Kato,

Thanks for the reply. No I didn't ditch the unit. After reading this and a few other forums I found the problem. I opened the front panel and disconnect the volume/menu board then turned on the TV.The volume bar went away. So I soaked some q-tips in some isopropyl alcohol and scrubbed the individual switches. I let it dry for a day and reconnected it. It has worked ever since, knock on wood.

Thanks again for the reply...

Kato
Kato's picture
MEB23 said: Kato, Thanks for

MEB23 said: Kato, Thanks for the reply. No I didn't ditch the unit. After reading this and a few other forums I found the problem. I opened the front panel and disconnect the volume/menu board then turned on the TV.The volume bar went away. So I soaked some q-tips in some isopropyl alcohol and scrubbed the individual switches. I let it dry for a day and reconnected it. It has worked ever since, knock on wood. Thanks again for the reply...

Great! You did it. It appears, as with many electrical connections that corrosion of somekind breaks the circuit or closes the circuit, as in your case it was the later. 

I think you tv will be good for a long time.

Thanks for posting and sharing.

techchallenged
techchallenged's picture
I have similar problem with

I have similar problem with my Mitsubishi. Just replace capacitors in the DM and TV would not work for some time. Tried plugging it in again and it starting working fine. Now it seems that the remote does not work and the front panel does not work properly either. What should I try first? This would be new to me after replacing the capacitors in the DM board twice already. Any advise is greatly appreciated.

MEB23
MEB23's picture
Steverw,

Steverw,

You might need to disconnect your switches from your control panel and clean them with Q-tips soaked in alcohol. After they are dry plug them back in and try them. If you need to replace them here is a link.

http://www.ebay.com/itm/100-PCS-MITSUBISHI-TACT-SWITCHES-432P109010-/380...

One more question when your replaced the capacitors did you replace the resistors also??

Good Luck....

techchallenged
techchallenged's picture
I did not replace the

I did not replace the resistors. Where are these located just in case the cleaning does not work. And thanks for all your help.

techchallenged
techchallenged's picture
Does anyone know what

Does anyone know what resistors MEB23 is talking about on the post above? Now my television has gone back to the green flashing light. I just replaced the resistors already.

techchallenged
techchallenged's picture
Im sorry, just replaced the

Im sorry, just replaced the capacitors not the resistors. I do not know where these are in question.

MEB23
MEB23's picture
Steverw,

Steverw,

Sorry about the delay in the reply. It was fuses not resistors, sorry. But if you go to tvrepairkits.com and choose tv repairkit and pick your TV. It will show you the capacitors and the fuses.

Here is the link for my TV.

http://www.tvrepairkits.com/xcart/mitsubishi-ws-65611-blinking-light-rep...

I'll try and find the pictures I took of my board and post them..

I hope this helps.

Also you might try e-bay, some people sell whole replacement boards.

techchallenged
techchallenged's picture
When I replaced the

When I replaced the capacitors I checked them with a multimeter. All is fine but now its back to the green light flashing. Was flashing before after I replaced the capacitors. I left it unplugged for a while then plugged it up after a few weeks and then it starting working. Remote stopped working and the controls on the tv. Came home from work one day and green flashing again. I know its time for a new tv but was hoping to keep this one going until we could get another. Is there some voltage checks I could do to see if anything is going on with something else. WS-55511. THX

 

Connect With Techlore