weird wireless issue

1 post / 0 new
Julai
Julai's picture
weird wireless issue

Hi Guys!

 

I'm just a newbie here so please bear with me while I'm trying to explain my weird wireless issue.

 

Here's my dilemma:

 

I have 2 laptops -- a (slightly new) Toshiba Satellite L310 and an (old) IBM Thinkpad (I don't know the model of this because the sticker that has it is gone).

 

Let me just say that I get free WIFI because I live beside the airport. But the problem is, my Toshiba (and ALL other wireless PCs/devices) can connect to the airport's wireless network EXCEPT for my IBM. It's weird because my IBM has NO problem connecting to OTHER wireless networks -- both secured (WEP/WPA) and unsecured -- in other locations, e.g. coffee shop, mall, library, hotel, etc. It just doesn't connect to the airport's WIFI! (It's really driving me crazy because it's the ONLY place where it doesn't connect!)

 

In my house, I only get 1 to 2 bars of wireless signal from the airport. It works fine for my other wireless pc and devices EXCEPT for my IBM.

 

Well, before I posted this, I already did a few things to check what's wrong:

 

--First, I asked the airport personnel if they are using MAC filtering -- they said no. (I didn't ask anything else because since all other wireless devices that used the same network before are still connected, I believe that they didn't change the SSID, wireless password, etc.)

 

--Second, I checked the wireless card info on my IBM. It has a built-in 802.11 a/b/g Wireless LAN Mini PCI Adapter (manufactured by: Philips Components; and has the driver version: 2.4.1.7).

 

--Third, I deleted all preferred wireless networks on my IBM, then I tried to re-connect to the same airport network and... it still failed.

 

--Fourth, I tried to manually configure the airport's wireless network info on my IBM and... it still failed.

 

Since everything that I have tried failed, I decided to post it here.

 

=====JUST A FEW GENERALIZATIONS:===== 

  Airport's WIFI Info: 

  • SSID: -- (no need to put it here)
  • Security Type: WPA-Personal
  • Encryption Type: TKIP
  • Network Security Key: -- (no need to put it here) 

  Problem PC's Info: 

  • Brand: IBM Model: Thinkpad (???)
  • OS: Microsoft Windows XP Professional Version 2002 Service Pack 3
  • Wireless Card: 802.11 a/b/g Wireless LAN Mini PCI Adapter
  • Driver Version: 2.4.1.7

   ===>doesn't connect to the airport's WIFI BUT can connect to OTHER wireless networks -- both secured (WEP/WPA) and unsecured -- in other locations.

    ===>receives the same 1 to 2 bars wireless signal strength that my other wireless devices use (without any problem).

==========


Until now, I really don't know what's wrong with my IBM Thinkpad. I can't figure it out.

I'm hoping that you guys, who are experts on this, can help me.

Thank you for reading my post.

 

Embarassed

 

Connect With Techlore