5 posts / 0 new
Last post

i've finally figured out that the canon xl-1s i recently bought hasn't been recognized by either by poWermac nor my firewire fs4, because its dv port isn't working. i know it's not the cable b/c i've tried several different cables.
nor is it a software glitch. neither iMovie nor final cut will mount the video.
additionally, when connected to my firestore, the DV IF indicator flashes.
my question is what to do about it.
a local repair shop has told me that if it's the board, it could cost me several 100 dollars AND UP.
this is the condition i received the camera, but it's taken me 2 months to understand what the problem is.
please HELP!

Matt Whitlock
If you only recently bought

If you only recently bought it, you should still be under warranty. Did you buy it used or from an unauthorized source?

i believe they haven't made

i believe they haven't made this model in over a year.
so. yes, i bought it used from an unauthorized 3rd party.
thanx for the thought.

Matt Whitlock
I've done a little more

I've done a little more thinking about your problem. Knowing whether or not the board in the camera is defective would certainly be helpful for diagnosing the problem. If it really is defective, there's not much you can really do besides get it fixed. I know your repair shop said "if it's defective", so maybe you could ask them for a more definitive answer.

I also was thinking... have you tried plugging in the camcorder to more than one firewire device? Do you have access to a PC with integrated firewire support?

i got the camera back today

i got the camera back today.
it is in fact the main board.
canon is not resposible.
nor the seller.
canon says that the part is never refurbished, so i must buy a new 1. how convenient.

as for trying different devices, i bought a new firestore fs4.
now completely useless, due to the inoperative dv port.

thanx for the input.
i'll keep u posted,


Connect With Techlore