mitsubishi WS65909 error code 23

2 posts / 0 new
Last post
delcobb
delcobb's picture
mitsubishi WS65909 error code 23

Unit Keeps shutting off. Error code 23. Any help would be great thanks

evil
evil's picture
Delcobb I am pasting our

Delcobb I am pasting our private message conversation here so that others may be helped by it if they run across this issue.

delcobb
July 17, 2013 2:14 AM
my ws65909 shuts off after awhile and I get error code
23. will this kit Mitsubishi WS-65909 Convergence Repair Kit fix my problem. Last kit was the cap replacement to fix the blinking green light issue about a year ago and it worked great. Any help would be great. Email is

evil
July 17, 2013 10:27 AM
I believe your chassis is V19 error code 23: is loss of horizontal deflection. It is common for this error to be caused by the FET or MOSFET that drives the flyback transformer. The link I provided for the previous guy will not fix your issue however I can provide you a link to a repair kit that most likely will. If you have a soldering iron and a manual remove the Horizontal Output Transistor or HOT and take it to be tested by someone who repairs electronics and make sure it is bad before replacing, they may possibly have a replacement there. There may also be some fuses that are bad, but if you install the new HOT and need further help feel free to write back. Also google images of "Horizontal Output Transistor or HOT" and flyback transformer to get an idea of what you are looking for on the boards of your tv. You will be working WITH very dangerous amounts of electricity so use common sense and safety measures as well as any knowledge you can read about.

delcobb
July 17, 2013 12:38 PM
Let me give you a little more info. Unit is still working. Works for a while then some horizontal lines start to show up and tv shuts down and I get error code 23. Other times after lines show up tv is like tuning in and all lines dissapear and all is good. This is starting to happen more and more fequently now so I know it is just a matter of time. Is this something I can fix myself. I have the manuals, DVM, iron ect.. just going to need what to test and what not. Thanks again for the feeddback

evil
July 17, 2013 4:06 PM
If you are getting lines in the picture before you are getting this error it is possible those are retrace lines, caused by a bad focus block but it is hard to tell without seeing them for myself, and pictures just don't do them justice. What are the intervals between when you get the lines and when the tv shuts down due to the error/short protect circuit? Does the picture turn a certain color or turn very bright when it shuts down due to the error?

delcobb
July 18, 2013 3:53 AM
lines are very faint and come and go kinda like the tv is trying to tune them out, then sometimes lines are much more apparent then picture dissapears into a bright center dot all in a split second. Sometimes tv stays on for minutes when line start to appear then other times it just shuts down when lines start to appear. If I let tv set for awhile 5-10 minutes can almost always turn it back on and it works good again
Once in awhile will see a brighter half inch or so warped line at just the top or bottom of screen
Hope this helps and makes some sense to you

evil
July 18, 2013 10:12 AM
The bright center dot somewhat affirms my thoughts of it being the focus block, not too sure about the thick lines on top and/or bottom. http://www.techlore.com/article/26744/G2-Adjustment-and-Electrical-Focus...... )When the error starts happening or when you have the time to do it try adjusting the knobs on the focus block. If the knobs aren't already marked in the current position be ABSOLUTELY SURE TO DO IT BEFORE ADJUSTING so you can return them to where they were originally. What you want to do with the tv off is just rock the knobs back and forth all the way to one side then the other a few times and back to the original position. This sometimes forces a better connection inside the focus block where it wasn't getting one before. Sometimes this can also just completely destroy what wasn't getting a connection but at least you will be able to confirm that is what it was.

evil
July 18, 2013 10:34 AM
I almost forgot, instructions to do this with the tv ON are completely different. If you see the lines appear and want to try this to see if it gets rid of them then mark the original position on the knobs and with the tv on rock the knobs back and forth GENTLY from one side to the other. If you rock back and forth to far with the set on you can destroy it. It only takes a very small amount to adjust these with the set ON. Also all of the red wires you see sticking out of the back of this block are carrying dangerous LETHAL amounts of electricity. Keep one hand in your pocket while performing the adjustment with the other. It is uncommon to have the blocks ark high voltage out and get you but I have seen it happen. It is always better to take a direct hit and have it leave you body through your leg than straight across your heart and out of your other hand.

delcobb
July 22, 2013 2:40 PM
ok evil did as you said and everything is working great have not had a problem as of yet thank-you so much for all your help

evil
July 22, 2013 4:03 PM
Good that's good to hear, if the problem comes back just try the suggested solution again and if it clears it up for any amount of time then you know you need a new focus block for your set but they are or at least can be somewhat difficult to find let alone exchanging out the old one, plus very dangerous for the aforementioned reasons. Given the massive amount of problems with the set it would probably be better to just keep adjusting it rather than keep throwing money into a lost cause.

 

Connect With Techlore