Dsi not recognizing games says no game inserted

1 post / 0 new
evil
evil's picture
Dsi not recognizing games says no game inserted

I recently came across one on eBay I'll try my best to describe how I fixed it. It was very simple without opening it I thought the answer was that the pins weren't making contact with those on the cartridge, the fix : I took a sheet of fine grain sand paper and tore a strip off as wide as the cartridge and with the grain facing up towards the pins in the Ds I inserted it, this can be tricky as it likes to stop at the pins when it hits them but you have to push it past the pins so when you pull it out it scrapes across the pins cleaning them so they will make contact, then you take a game after putting the sand paper in and gently insert the game, not all the way but atleast to the pins, then pull out the sand paper while holding the game in. That's it!!! Cleans the pins so they make contact with the cartridge pins. Worked like a charm.

 

Connect With Techlore