need help with stereo receiver

8 posts / 0 new
Last post
rzberri
rzberri's picture
need help with stereo receiver

I have a techwood ddr 95 av digital surround receiver. Not getting sound after connecting speakers. Thought it may have been fuse. Changed that but no sound coming out of speakers

Matt Whitlock
Matt Whitlock's picture
Few simple but oft-overlooked

Few simple but oft-overlooked things first:

1. There's a TAPE 2 (monitor) button on the front panel. Make sure it's not engaged.

2. Depending on the device you have hooked up, make sure you check the Digital input button so you're not forcing the receiver to the wrong digital input, or that you're not looking to a digital input when the source is analog.

3. Make sure you didn't plug the fronts into "Speakers B" and that "Speakers A" is selected.

rzberri
rzberri's picture
i did that. I can here when i

i did that. I can here when i connect the speakers up, but yet i still fail to obtain any sound

Matt Whitlock
Matt Whitlock's picture
Hmmm...

Hmmm...

Can you share anything else you've tried?

When you set the receiver to TUNER, do you get anything out of the speakers? Even static?

rzberri
rzberri's picture
the only thing i hear is the

the only thing i hear is the static from when i connect the speakers. i can hear the connection but yet still no sound. i have tried everything. i am sure the speakers are connceted correctly.

dans_repair_service
dans_repair_service's picture
If you are hearing static,

If you are hearing static, the outputs are OK. Is this a new unit? Are there pre-amp outputs in the back? If so, try connecting from those outputs to another amp. Sound=preamp/switching sections working OK. If nothing, then the pre-amp section has a problem. Check for sound at the tape-out jacks. See if the inputs switch. If not, than I'd suspect the internal electronic switching chip. It may be a TC9163 (from memory).
Keep us posted.
Dan

LeMon Roberts
LeMon Roberts's picture
my light r not coming on, its

my light r not coming on, its working but i cant see not but can hear it

Shaber
Shaber's picture
I seem to be having the exact

I seem to be having the exact same issue - were you ever able to figure out the cause?

 

Connect With Techlore