Mitsubishi ws-65611 problems

99 posts / 0 new
Last post
Lord Crystallion
Lord Crystallion's picture
Larry, My WS-65611 has a

Larry, My WS-65611 has a green haze or fog to it. I've tried adjusting the Red & Blue color but nothing works. This is only if I use the HDTV setup. I assume I have a bad board. Do you have the schematics that will show me which board I need to replace. Any help you can provide is greatly appreciated.Dakota5883@yahoo.com

KevinS
KevinS's picture
I have a WS-65611 and would

I have a WS-65611 and would like a copy of a service manual, my convergence is bad, both top and bottom of display is bent inward. My email is searsk@cox.net I would really appreciate any help. I do have some technical skills would work on this myself if not too complicated.

kyleraid
kyleraid's picture
Larry,

Larry,

My ws-65611 has a bad dm module from what the tech people tell me over the phone. is this somehting that i can fix myself or is there somewhere i can buy a new or repaired dm module that i might be able to replace myself? Thanks for any info. my email is kyleraid@yahoo.com

looney
looney's picture
Larry Dillon said: It is on

Larry Dillon said: It is on it's way to you. Good luck

Hi Larry, Looney here I have not received any info yet on the mitsu 65611 flashing green light

could you resend that info again please Thanks hallicom@hotmail.com

kyleraid
kyleraid's picture
i replaced my capacitors but

i replaced my capacitors but the green light does not stop flashing. Do you need to put the back of the tv back on or will it work without it?

jhruzek
jhruzek's picture
Larry,

Larry,

I have a Mitsubishi WS55511 with the same problem as started this thread. My set randomly shuts off with the message about power ac line failed or connections for RGBHv or yPrPb may be invalid. Could you email your manuals/instructions to jhruzek@chco-cpas.com? Any other thoughts would be greatly appreciated.

jhruzek
jhruzek's picture
My set is now fixed. My tech

My set is now fixed. My tech replaced the connector at location "KE" and everything is now working as it should.

Greg4773
Greg4773's picture
The same thing happened to my

The same thing happened to my TV regarding the volume control with a mind of its own.  I cant get it off my screen.  Read that it could be a bad capacitor on the DM board.  Could someone please forward me the repair instructions?  Thanks.

dragonhue2
dragonhue2's picture
larry i have noticed that you

larry i have noticed that you havent reply tosome of the posts,are you still around.i am having a different problem with my ws 65611 .i have no power to get a flashing light.when i plug it in i hear a

dragonhue2
dragonhue2's picture
hi larry ,my problem is a

hi larry ,my problem is a little different.i dont have any power at all.when i plug the tv in i hear a "ping"? i dont have any light on front of tv or it doesnt turn on.any ideas,,thanks

bryce
bryce's picture
id really like the service

id really like the service manual for a mits ws65611 if i can get one. thanks

mommieofone
mommieofone's picture
The bright colors on my

The bright colors on my Mitsubishi ws-65611 have become dull and look blue, gray, and orangy/yellow. I went through all the color setting but none changes them back to normal. Does something need to be replaced or is there a way of fixing this? I have done the system reset as well. Any info would be great, thanks.

jhruzek
jhruzek's picture
I had a similar problem. I

I had a similar problem. I have my cable box feeding to my Mits WS55111 using the 3 RCA connections for Yp, Yb, etc. I found that one of the wires had pulled loose.

ITGUY
ITGUY's picture
I have a WS-65611 that will

I have a WS-65611 that will not turn on. Everything was working fine until we sent back the Dish Network Cable box (unplugged while everything was off). My son tried to turn it on to play a DVD and said that it just turned itself off after a few seconds.
So, I am thinking a power supply problem? No Light's go on and I did not see if the green light blinked before it went off.
I am a veteran IT guy and my kid's would appreciate any advice that you can provide to me so that I can fix it.

Thank You,

osman
osman's picture
I have a similar problem as

I have a similar problem as ITGUY, every time I reboot my WS65611, the green light in the front would flash for several seconds and turn off. I was told to check 2 fuses F9A04 and F9A05 which I could not find. As I opened the back, I saw 3 boards with names marked on each board; 1) A signal board with IC's and surface mounts parts to the left, 2) A DM board with voltage regulators and capacitors/inductorsin the center and 3) a main board with high voltage circuitry to the right. last year I hade a different failure mode, picture would diverge to show a shadow. When I called a local TV repairman he replaced the DM board for $700. Any idea how I can fix green flashing light problem?

Rod Crutchfield
Rod Crutchfield's picture
Hi Larry~

Hi Larry~
I own a Mitsubishi 65' rear projection HD TV model WS65611.
I am experiencing a problem with the remote and front control panel not changing the input on the TV.
The on/off button also is not responding to the remote and I must push the front panel on/off button numerous times for it to respond.
The remote is operational as it works other things. I have tried resetting the TV with the reset button and unplugging the TV for a few hours.
I have blown the front panel controls with air to dislodge any possible debris.
Can you please advise me as to what the problem might be and as to how I can repair it myself?
Also can you please forward the PDF service manual to me?
Thank you,
Jeff

mtense
mtense's picture
Hey Larry, I have a WS-65611

Hey Larry, I have a WS-65611 from Dec 2002 with the blinking green. Hoping capacitor replacement will fix it. I would really appreciate your instructions. Please email to mtense@gmail.com. Happy Holidays, Aaron

TimH
TimH's picture
Hi,

Hi,

I have a WS-65511 from about June of 03, and it started today where it would turn on, but the power light would stay on for only a second or two, then shut off.

The blink code appears to be 2 2.

Is this a DM module issue, and if so, can you send the cap replacement doc to tim at honl dot net ?

Thanks very much for your help!

TeeGee
TeeGee's picture
Larry, we experienced a power

Larry, we experienced a power surge/outage a few days ago, and ever since then I have been experiencing the dreaded "blinking green light" on my Mitsubishi WS-65611. I have checked the front switches (by pulling the harness cable) and that is not the source of the problem. I will check the capacitors on the DM tomorrow when I get off work, and I think that I'm likely to find the tell-tale bulges. I would appreciate it if you could send me the repair guide for the capacitor fix when you get a chance.

My e-mail address is jcinman2@verizon.net.

Thanks!

Ohio Scott
Ohio Scott's picture
Green Lights of hell.

Green Lights of hell.
Dude split a power poll by the home and we lost power. When power was restored green lights were flshing on ws-65611 and it would not turn on. Tried reseting and nothing. Tried unpluging and nothing.

I have read about this dm board and replacing caps. Please send all info regarding this and how to fix it manual. I would greatly appreciate it.

send to firebaseball@yahoo.com

Hobart31
Hobart31's picture
I have this exact problem too
Hobart31
Hobart31's picture
I have this exact problem too
Doug Dean
Doug Dean's picture
Hi! I also have a WS-65611

Hi! I also have a WS-65611 and had a similar problem. In my case, none of the remote controls worked and only the power button worked on the TV set. When the TV was on the screen showed just fine except that many menus were showing and the main input feed selection display was skipping by itself from device to device. The menu button didn't work on the control or the TV. System reset didn't help. I tried pressing and holding Menu and Device (my set has no Input) and voila! The menu settled down, and the remote worked again. Thanks for the suggestions, guys!

Doug Dean
Doug Dean's picture
Hi, guys! I had a very

Hi, guys! I had a very similar problem... remote didn't work, only On/Off on the TV worked and also when the screen did show, the device menu was showing and cycling continually around the feeds without selecting any (it happened to be on cable, so behind it I got a cable picture). System reset 3 times, no luck. Then after reading this article I tried pressing and holding Menu and Device to get the error code and voila! The menu settled down, I could hide it and the remote worked again. Thanks, guys!

Rocky Chandra
Rocky Chandra's picture
Larry

Larry

I have a ws65611 TV set.... but appears the remote is working but the TV set does not respond. What should I do ?

charlsweb9
charlsweb9's picture
Larry,

Larry,
My WS-65611 won't turn on at all. I have verified that there is power coming from the outlet yet no response from the tv when I press the power button. No lights whatsoever. The remote does nothing as well.It was very sudden, it worked one day but not the next. I have an electrical engineering degree so I am familiar with circuit boards. Any help you can give would be great.
Charlotte

Rocky Chandra
Rocky Chandra's picture
Larry Dillon said: how do you

Larry Dillon said: how do you know the remote is working??

Larry, in order to buy a replacement remote, I went to a website that asked me to press every buttom on the remote for each device setting (TV, 4etc). I did that. It then aslked me to see if the the remote was sending a signal as a reflection on the screen of a cell phone. I could see the reflection of the light the remote has . I concluded that the remote was working.

 

I also did the reset on the TV .... but again the TV does not recognize the signals from the remote.

 

Then I logged on to this site and read some posts .... and appears that other people have similar issues though.

Corber
Corber's picture
Please email me the repair

Please email me the repair PDF also. I am having the same problem with my WS-55511. brazen5573@yahoo.com

Wyatt E
Wyatt E's picture
Good morning Mr. Dillon! I

Good morning Mr. Dillon! I have what appears to be the same issue with the flashing green light, can you email the service manual and pictures to me as well? I would greatly appreciate it! Thank you!!

Ohio Scott
Ohio Scott's picture
Mr. Dillion,

Mr. Dillion,
I recently unplugged my ws65611 from a power strip and when i replugged the tv in the blue convergence was off. i went to the convergence area in setup and the word blue was distorted and fuzzy. also the word blue is showing x3 ( blue blue blue all fuzzy and distorted). I tried to center the the words and they came within 1 inch of center and would not go left any further. Any ideas ? I know you got some your the man !

firebaseball@yahoo.com

Pages

 

Connect With Techlore