Casio Scientific Calculator

4 posts / 0 new
Last post
R&D Man
R&D Man's picture
Casio Scientific Calculator

I have a Casio fx-7000GA Scientific Calculator and have retrieved it from storage from within my desk. It would not display. Therefore, I changed the batteries and tried resetting it. Still no display. IF anyone has a clue as to what may be casuing this please let me know. I have no repair manual, nor do I know where in the US to locate one. If there is a firm that works on these calculators, I have yet to find them. Help would be greatly appreciated. I'd prefer to correct this problem without additional cost if possible. Please advise . . .

Matt Whitlock
Matt Whitlock's picture
It could be something simple,

It could be something simple, like a contrast adjustment. Look for an adjustment (either a wheel, or a combination of key presses) to adjust the contrast.

R&D Man
R&D Man's picture
Matt Whitlock said:It could

Matt Whitlock said:

It could be something simple, like a contrast adjustment. Look for an adjustment (either a wheel, or a combination of key presses) to adjust the contrast.



Thanks for the TIP! Oops! No wheel, it's mode arrow up and arrow down on this model. Now you've got me searching for my operators manual to make sure I'm using the functions properly. Just can't really tell since nothing is showing on the display.

Here is an actual image of the Calculator for reference.

I've put new batteries in, tunred it on, reset it, and held down the right and then the left arrow and still no visual on the screen and I've also been pressing the "AC" on as well. Any more ideas?

Matt Whitlock
Matt Whitlock's picture
Calculators are not super

Calculators are not super-complicated devices, and usually either work or don't work.

Thinking....

It looks like a slightly older model. So lets focus on the batteries and battery terminals. Check for corrosion on the terminals, or anything else that may interfere with getting juice into the calculator.

Next, check for a button cell backup battery somewhere in the battery compartment. I had an orgaziner years ago that refused to turn on if the backup battery was dead, even if the main batteries were new.

Double check your new batteries. Make sure they're inserted properly and orienated the correct way. If so, try another new set from a different package. I've gotten new packs in the past that were duds from the start.

Try those and post back.

 

Connect With Techlore