JVC AV-2795S tv problem when tuner is in use

5 posts / 0 new
Last post
talyn
talyn's picture
JVC AV-2795S tv problem when tuner is in use

The last two days this tv is randomly having "snow" appear while watch tuner channels. This happens on all channels and is getting worse day by day. Line-level devices like dvd do not have any problems. Any advice on what is causing the tuner channels to come and go?

Matt Whitlock
Matt Whitlock's picture
The first thing I would try

The first thing I would try is checking the coaxial cable between the source and the TV's tuner. You may need to replace a bad section of cable or a splitter.

A good way to diagnose is to hook up a VCR or other device to the TV's tuner using a different coaxial cable. If the internittent snow continues, start checking the wires.

talyn
talyn's picture
I tried a different cable

I tried a different cable with no change in performance. I moved the TV to a different part of the house and the same problem appears within minutes of turning on the TV. This TV is 10 yrs old and when I put a different TV in its place no problems are every seen. Are there parts that are more likely to degrade on the tuner section of the TV? Thanks for any advice.

Matt Whitlock
Matt Whitlock's picture
Sounds like a short or

Sounds like a short or failing tuner. You'll need to contact an authorized JVC service center in your area to have it diagnosed and quoted. Since it's a 27", you'll save a few bucks if you can carry it into the shop rather than have it looked at in home.

Click here to find a service center in your area.

bwiz
bwiz's picture
My tv is having the same

My tv is having the same problem and I want to know how much it would be to get this fixed. Or is it better to just get a new tv? I had the cable man diagnose the problem thinking it was the cable.

 

Connect With Techlore