JVC TH-C50 Home Theater

The unit will not turn on.  The outlet it is plugged into has power.  Is there a fuse in this unit?

SirCampsAlot
SirCampsAlot's picture
Hi, my reciever will stay on

Hi, my reciever will stay on for awhile then randomly shut down into standby mode. Sometimes it will stay on for a few days and others for a few minutes. What could be wrong here?

Jeremy_b
Jeremy_b's picture
I have the same problem no

I have the same problem no power it does show blue light then red light then nothing I replaced fuse that did nothing.

JVCme
JVCme's picture
Jason or Gibbs,

Jason or Gibbs,
Did you ever resolve your JVC's no power issue? I currently have the same model and problem (no light, no sound, just no power). I'm ready to head to Radio Shack instead of Best Buy! Anyone please let me know how to fix.

rob. k
rob. k's picture
I had the same alternating

I had the same alternating light show on the th-c30 or the standby light just comes on for a second then off again.

Anthony M
Anthony M's picture
I have the TH-C50. i replaced

I have the TH-C50. i replaced the fuse and it does not blow but when I plug the power cord in the standby light will come on and go off within a second. If I take the cord out and put it back in...nothing but if I wait a while the light will come on and go right back off.

Kyle24
Kyle24's picture
SirCampsAlot -

SirCampsAlot -

I am having the exact same issue as you. Have you found a fix yet?

When the issue started, the system could stay on for hours and then go into standby mode (red light). Then it got worse and would only stay on for a few mintues before going back to standby. Now the system will turn on for 1 second and immediately return to standby mode.

I replaced the fuse even though I was sure this wasn't the problem - nothing changed.

Lucien
Lucien's picture
Mine's doing the same thing.

Mine's doing the same thing. I went to Radio Shack and got the fuse everyone is talking about and it does match 1 amp, 250 volt 5x20mm slow blow, but it is glass. it doesn't do anything. doesn't blow again, just does nothing. Anyone help??

Not a gadget junkie
Not a gadget junkie's picture
I have a TH-C50. I recently

I have a TH-C50. I recently moved & switched cable companies so I now have an HD cable box. I've never had issues with my analog box feeding sound, but have from day 1 with this HD box. I bought a digital optical audio cable, but it didn't solve the issue - when I turn the receiver on, I get no sound. I change the source to tuner & get sound. Oddly, when I switch it back to VCR (DBS D since get the optical audio cable), there's sound!

My original thought was that it needs time to warm up, but I've left it sitting for far longer than it takes to switch the source input & that doesn't work! Please help!!

MrBib2000
MrBib2000's picture
I have a similar problem.

I have a similar problem. After we lost power in a storm (no lightning strike) I can unplug the unit, then plug it back in. The red power light and blue illumination light come on for a second, then both go out. I ohmed out the fuse and it's good. Not sure where to go from here. However, for others with similar problems, I found I could rescue all but one of my disks. With the unit's cover off, look at the visible side of the DVD trays. You will see the side of a gear on each tray. Hold the spring-loaded front cover open with one hand and rotate each gear with your other hand. One direction will eject the tray (and disk) the other will close it. Couldn't get the disk out of the player itself. It transfers from the tray to the player. Anyways, any help would be appreciated.

Gibber08
Gibber08's picture
When we try to turn the unit

When we try to turn the unit on, the lights will flash jjust breifly and then shut off. We read about the fuse and replaced it but it still does not stay on.
Is there another fuse that we might need to look at?

AirmanSparky
AirmanSparky's picture
I get the no sound problem

I get the no sound problem too. everything turns on but the dvd player dont work and no sound comes through. i tried even using optial line to get sound too but still nothing. does anyone know where i can get the schematics to troubleshoot it? i can find the problem and fix it for sure if i had those.

worm
worm's picture
Need schematic for xv-thd50

Need schematic for xv-thd50 Dvd Found burnt resistor need to know vavle R1403

Brenda D.
Brenda D.'s picture
Hi, Replaced ceramic fuse and

Hi, Replaced ceramic fuse and still no power. Can anyone help me?Thanks!

kingly
kingly's picture
where can i find the standby
where can i find the standby power supply?  
kingly
kingly's picture
where can i find the standby
where can i find the standby power supply?  

Pages

 

Connect With Techlore