Rear projection TV STK 392-120 LG convergence problem

125 posts / 0 new
Last post
dayawansha
dayawansha's picture
gte,,

gte,,
yes i forgot this model having auto convrg,,u r right..
so....,,chk STK board near the -26 & +26volt connector having 2 resistors,,
its value are 0.47ohm,,its around 1watt,,,check both resistors values are not
gone higher than 0.47 ohms,,remove the resistors & check pls,,,bec if the input
volts are dropping to the STKs similar like this all 3 colours will disturb..

ello1828
ello1828's picture
I changed resistors at the

I changed resistors at the location R2095 and R2096, when I put the conv board back, i could smell both ICs and when I put my figure tip on both ICs - they both were too hot.

Any reason why this would happen ?

Larry Dillon
Larry Dillon's picture
triple check the soldering

triple check the soldering for soldering shorts, please go to tvrepairkits,com/helpdesk and open up a trouble/repair ticket please
Larry D.best way to tell if the soldering is take a toothpick and make sure you can pass the end between each solder connection
Larry D.

latas
latas's picture
Hi Guys. First of all, thanks

Hi Guys. First of all, thanks about all your help. I'm from Spain. I've got an LG 40NZ60RB. My symptoms were the same as all of you says. The convergence was broken, and I saw red lines curved. Following instructions on this forum on others I bought two STK-392-120. I soldied them, and then, I watched the TV and I saw the curved red lines become rect lines.

But the convergence problem still persists.

Following your instructions entering Service Mode, I keep presing MENU button on the remote control at same time MENU button on TV buttons.

Then I played a lot with the service menu.

Magically once in the Convergence menu of the service Menu I pressed the TEXT button in the Remote Control, the one button on the right of the PIP button, and WOW!!!!! al the GRID of the convergence menu was synch, all the lines converged magically.

Then I used the menu to SAVE at 50Mhz and SAVE DATA, BACKUP and all saying SAVE I used it :) to keep my new configuration.

Afterthat I powered off the TV. I put all the screws.

Then when I powered on again, the Convergence option in the standard Menu was enabled again :)

Coooool!!!

ello1828
ello1828's picture
I COULDNT FIX THE TV AFTER

I COULDNT FIX THE TV AFTER ALL EFFORTS AND BOUGHT NEW tv. ANYONE INTERESTED IN FIXING THIS TV OR WANT TO BUY PARTS OF THIS, POST YOUR VIEW HERE.

Lamps to start with could be good.

Squirel
Squirel's picture
Hi all,

Hi all,
re convergence fault LG RT39NZ43RB

Should I replace the pair of STK392-120 or what possibility do I have fixing convergence by just changing the resistors?

Thank you!

Al in Australia

dayawansha
dayawansha's picture
Squirel said: Hi all, re

Squirel said: Hi all, re convergence fault LG RT39NZ43RB Should I replace the pair of STK392-120 or what possibility do I have fixing convergence by just changing the resistors? Thank you! Al in Australia

........Squirel..,,,have u received the burned resistor values from anyone...?

        i am daya from saudi arabia..

smatt
smatt's picture
Hi I have a convergence

Hi I have a convergence problem, replaced the STK's and the resistors as I had two blown but I replaced them all, once putting everything back the picture came on I was in the middle of doing the convergence when the tv just went off. Now it won't come back on. If I disconnect the board then tv will come back on but obviously you can see the convergenc out. What do you think is wrong?

Many thanks

Matt

dayawansha
dayawansha's picture
smatt said: Hi I have a

smatt said: Hi I have a convergence problem, replaced the STK's and the resistors as I had two blown but I replaced them all, once putting everything back the picture came on I was in the middle of doing the convergence when the tv just went off. Now it won't come back on. If I disconnect the board then tv will come back on but obviously you can see the convergenc out. What do you think is wrong? Many thanks Matt

Matt,,can u tell me whether this is a LG tv,,,if so can u mention the model # pleezz...thanks,

smatt
smatt's picture
Hi

Hi

Many thanks for your reply the model no is LG RE39NZ40

dayawansha
dayawansha's picture
dayawansha said:

dayawansha said:

smatt said: Hi I have a convergence problem, replaced the STK's and the resistors as I had two blown but I replaced them all, once putting everything back the picture came on I was in the middle of doing the convergence when the tv just went off. Now it won't come back on. If I disconnect the board then tv will come back on but obviously you can see the convergenc out. What do you think is wrong? Many thanks Matt

Matt,,can u tell me whether this is a LG tv,,,if so can u mention the model # pleezz...thanks,

Matt,, u have mentioned there was 2 blown resistors,,but u replacd them all,,wht u meant by tht,,have u replacd all the resistors on the board...?

other thing u have mentioned u were doing the convergence & the tv went off,,,i think this tv is auto convregence type,,so u cant do it manually,,is it...?

smatt
smatt's picture
Hi Dayawansha

Hi Dayawansha

Yes I replaced all the resistors which were the 220 ohm 2w and the 3.9 2w 24 in total. You can manually do the convergence on my tv where you adjust all of the crosses on the screen. Whilst I was doing this the tv suddenly went off, and now wont come back on with the board connected. If I take the board out the tv comes on but you obviously get the colours out of sync because the board is not connected.

dayawansha
dayawansha's picture
smatt said: Hi Dayawansha

smatt said: Hi Dayawansha Yes I replaced all the resistors which were the 220 ohm 2w and the 3.9 2w 24 in total. You can manually do the convergence on my tv where you adjust all of the crosses on the screen. Whilst I was doing this the tv suddenly went off, and now wont come back on with the board connected. If I take the board out the tv comes on but you obviously get the colours out of sync because the board is not connected.

Matt,,,normally those burnd 2 resistors only need to be replacd,,anyhow now wht u have to do is,,,there is SMPS board right side,,its mounted vertically,,which connected with the power cable,,take tht board out & carefully check the voltage out paths for -26 volt & +26 volt......,those paths are connected through fuses,,its black colour & square type fuses,,just measure these fuses with your multimeter,,& normally all will show 0 ohm or 0.1 ohms,,,,but 1 of fuse will show around 4 ohms,,,actually tht fuse is open,,but its reading through the transformer & showing tht 4 ohms,,so someone may think its good, but its open...so wht u must do is,,,simply jump tht fuse with a thin wire,,,its much better u jump both fuses for -26 volt & for +26 volt,,,because later other fuse also can get open....pls check all the square type fuses connected with the transformer T 801 output voltages...

smatt
smatt's picture
Many thanks for your help

Many thanks for your help with this it is much appreciated. I will give it a try tomorrow and let you know what is happening.

I may ask you for your help tomorrow if i get stuck checking this if that is ok

dayawansha
dayawansha's picture
smatt said: Many thanks for

smatt said: Many thanks for your help with this it is much appreciated. I will give it a try tomorrow and let you know what is happening. I may ask you for your help tomorrow if i get stuck checking this if that is ok

No probs matt,,,check & tell me....mostly this maybe the problm,,these fuses somtimes gets open,,,its normal,,,,so do not hesitate to jump those,,,,hopefully this maybe the problem...

Lotus1
Lotus1's picture
Reviving an older post, just
Michigan Jeff
Michigan Jeff's picture
Hello everyone. This is a

Hello everyone. This is a very useful thread which I would also like to revive.
I replaced the STK ICs in my JVC rear projection AV-48W74 TV about four years ago after developing a convergance problem. Now, the TV has developed a similar problem again. The picture has a distorted red shift which sometimes goes away after the TV has been on for a long time. When viewing the manual convergence screen, the red grid is shifted, warped, and in some placed shaking. I can manually adjust both the red and the blue grids.
I have not isolated and checked any of the resistors, but they all look to be in good shape; no burns or discoloration. The intermittant nature of this issue makes me question whether it is one of the STK ICs again, or something else. I would like to post a couple photos of the picture, but not sure how to do so on this forum.
Thanks in advance.

Jeff

dayawansha
dayawansha's picture
Michigan Jeff said: Hello

Michigan Jeff said: Hello everyone. This is a very useful thread which I would also like to revive. I replaced the STK ICs in my JVC rear projection AV-48W74 TV about four years ago after developing a convergance problem. Now, the TV has developed a similar problem again. The picture has a distorted red shift which sometimes goes away after the TV has been on for a long time. When viewing the manual convergence screen, the red grid is shifted, warped, and in some placed shaking. I can manually adjust both the red and the blue grids. I have not isolated and checked any of the resistors, but they all look to be in good shape; no burns or discoloration. The intermittant nature of this issue makes me question whether it is one of the STK ICs again, or something else. I would like to post a couple photos of the picture, but not sure how to do so on this forum. Thanks in advance. Jeff

Hi Jeff,, I am mostly familiar with LG & PHILIPS projection TVs,,I thnk JVC also using STK 392-120 ICs,,,I remember once I replacd the same # in one JVC projection,,anyhow dont worry about this intermittent nature,,after sometimes it will be permenently stay,,some cases it comes like this intermittent & later will be permanent,,so if you are thnkn to replace only 1 STK then just find out which one controlling RED colour then replace tht...Resistors will not burn in this intermittent case,,,but when it happen permenantly then resistors may burn....So its better replace in this stage....Normally in LG & PHILIPS projection TVs I am replacing in every 2 or 2 1/2 year time limit,,,so in your case 4 years has done,,,,its a long period STKs to work accordn to my experience,,,,,so...,just reeeeplace it.....goodluck,,,,,i am daya from Jeddah,,SaudiArabia.(Remember to apply Heat Sink Compound,,,also Clean Well  before applied Compound on the HeatSink Base, then apply again New Compound )..

Michigan Jeff
Michigan Jeff's picture
Thanks Daya. How wonderful

Thanks Daya. How wonderful that someone is eager to help from half a world away!
Another question. Is there a safe way of determining which STK IC is responsible for the red convergence? Can I disconnect one of the wire connectors and then observe what happens?

Jeff

ktkoo
ktkoo's picture
I just had the IC chips

I just had the IC chips changed by our electronic guy. Picture improved heaps, needed a bit of tweaking with manual convergence to get it perfect. Only problem is when we turn of the power it reverts back to the factory setting even though I've saved data control set. What step am I missing? Any suggestions would be great. We used an XBOX plugged into component 1 to get a picture as there is no aerial on that room. Like I said worked fine until we turned off xbox and tv.

redsock
redsock's picture
When I did mine I had major

When I did mine I had major hassles with this, turned out I was using the incorrect "save" menu item, and that I had to save them individually for 50hz and 60hz from the right menu spot.

I don't have the docs anymore though...

smatt
smatt's picture
Daya,

Daya,

Many thanks for your help earlier in the thread I bought some more STK chips and all went well this time TV fixed and all working good.

Thanks again for your expert advice it is much appreciated.

Matt

Sipheren
Sipheren's picture
Hi,

Hi,

I fixed my tv about 6 months ago, new ic and replaced resistors on the conversion board and the tv has been working fine.

The past few weeks I have started noticing the red separating, I can fix it manually but it only lasts a few days.

Auto converge doesn't fix anything either.

What would be the issue, surly the ic's aren't dead already?

Sipheren
Sipheren's picture
Edit, I was just adjusting

Edit, I was just adjusting the convergence manually and pressed something and one the image is all curved, seems like all 3 collies are concave and at different angles.

Anyone have any idea how that happened? Or how to fix it?

Edit: it only does this on the xbox channel which is 60hz, all other formats (50hz) work perfectly.

How can I reset the 60hz settings?

EliLilly
EliLilly's picture
I have a Philips 51PP9303h/17

I have a Philips 51PP9303h/17 and a few months back I had to replace the crt fluid and clean both the blue and green lamps. Now after everything was fine this morning when I turned it on this afternoon the left and the bottom colors are out of whack. I tried the multi point convergence and it didnt work at all. It seems that the red is effected the most. With what I have read it seems that the IC board maybe out or on its way out. What ever suggestions you can spare would be greatly appreciated.

evil
evil's picture
For convergence issues go to

For convergence issues go to the website below for a complete repair kit.

gazi
gazi's picture
My rptv screen is display red

My rptv screen is display red colour all over..!!
mixing of colours is not taking place ..!! it is displaying only 3 colours red green and blue... No other colour is being displayed...Please help..!!
Thanks..

evil
evil's picture
Gazi these three colors make

Gazi these three colors make up every color you see on tv. The issue is that they are not aligned right. If you go to the link below and find your make and model there will be a picture with the repairkit that shows what this issue looks like. If you think you can handle the repair click the button to buy it. It has everything you will need in order to repair it including instructions.

gazi
gazi's picture
Thanks for reply 'evil'...But

Thanks for reply 'evil'...But I have aligned the colours in convergence menu..!!
My screen is too red...!!
Every thing appears red in it. colours for menu items are ok but there is problem with red colour in the picture being displayed..!!
please help me
thanks..!!

evil
evil's picture
Can you post a picture so I

Can you post a picture so I can get a better idea.

Pages

 

Connect With Techlore