Rear projection TV STK 392-120 LG convergence problem

125 posts / 0 new
Last post
rich321
rich321's picture
dayawansha said:

dayawansha said:
RICH 321,,,,IF U STILL HAVE THE PROB REGARDN UR 'LG' TV,,WRITE TO ME,,I WILL HELP U SURELY,,ANY ONE WITH LG TVs ASK ME,,I AM A SRILANKAN...

dayawansha / larry dillon

yes i still have more problems with my LG RE-39NZ43RB the sound went dead so I switched
the TV off standby for 1 hour when I switched it on again it crackled
and clicked so I switched of at the plug for 1 hour and when I switched
on this time no sound and I also have a convergence problem I then auto
converged the Tv,the convergence was ok but still no sound.

And now I have no sound no picture from all inputs eg AV,s / S-VIDEO. Also COMPONENT OSD will not display although all the other OSD will display OK the OSD is now not converged and I am also unable to select auto converge.

In
november I replaced both OF STK392-120 IC and resistors which fixed a
convergence problem. I also replaced a axial lead inductor which I damaged.

I would appreciate any help please.

dayawansha
dayawansha's picture
do u mean,,ur TV now havn OSD

do u mean,,ur TV now havn OSD workn????means when u press the remote,,does the MENUs comn on the screen???? & u are sayn no picture & sound,,,is it the condition now ???
if there is no video signal u cant go to converge mode...

rich321
rich321's picture
dayawansha said:

dayawansha said:
do u mean,,ur TV now havn OSD workn????means when u press the remote,,does the MENUs comn on the screen???? & u are sayn no picture & sound,,,is it the condition now ???
if there is no video signal u cant go to converge mode...

I changed the 2 convergence IC's some resistors and a indutor (which I damaged) in november and all was ok untill now.

first the TV made cracking noises  then the screen went blank then came back lots of times then it de-converged. I then auto converged the tv and it was OK, then after switching of and back on later no sound & picture?

yes I have OSD working when I press menu on remote (but OSD is not converged) yes I do not have  picture & sound when DVD player is conected to AV,1,2,3, and no picture when RF socket conected to TV arial.

component will not sellect pressing TV/AV or MULTIMEDIA on remote

thanks for replying

 

 

Marco Antonio
Marco Antonio's picture
Normally ic converge is bad

Normally ic converge is bad because the place is cold reeplace ic and access service mode tv proyection

dayawansha
dayawansha's picture
rich 321,,u have mentioned

rich 321,,u have mentioned after doing auto converge tv was ok,,means converge also was ok??,,,then after switchn off & on,,,,was the converge went out again ??......i would like to know what kind of cracking sound u have mentioned??......is it like "high voltage spaking" sound?...is it possible you to attach a picture of your screen with the OSD please.....thanks,,daya.

rich321
rich321's picture
dayawansha said:

dayawansha said:
rich 321,,u have mentioned after doing auto converge tv was ok,,means converge also was ok??,,,then after switchn off & on,,,,was the converge went out again ??......i would like to know what kind of cracking sound u have mentioned??......is it like "high voltage spaking" sound?...is it possible you to attach a picture of your screen with the OSD please.....thanks,,daya.

yes after doing auto converge just picture OK (but cracking sound like sticks snapping in speakers i think and no smell, but no audio from speakers and screen went blank and back on lots of times)

then stopped converging, it was possible to select auto converge but would not auto converge and no cracking sound and no audio.

then after power off and on over night no picture no sound no cracking sound, OSD not converged and not posible to select auto converge.

 

                    

 

dayawansha
dayawansha's picture
rich,,,its looks convergence

rich,,,its looks convergence ICs may got damagd again,,its before 5 months u have replacd both STKs no,,,anyhow 1 st now u have to follow why there is no video comn with the inputs,,,may be there is a connection with that cracking sound u heard before,,,it can be one of your CRT given high voltage leaking before,,,thts why you have heard a crackin sound i thnk,,,,so this high voltage
may have done somthn to video circuits,,,or it have has changed the option codes
due to the sparking,,,,just give me sometimes to check the service modes & will let you know to check somthn in service modes,,,,are you able to find a service remote control from your local LG service center ??

rich321
rich321's picture
dayawansha said:

dayawansha said:
rich,,,its looks convergence ICs may got damagd again,,its before 5 months u have replacd both STKs no,,,anyhow 1 st now u have to follow why there is no video comn with the inputs,,,may be there is a connection with that cracking sound u heard before,,,it can be one of your CRT given high voltage leaking before,,,thts why you have heard a crackin sound i thnk,,,,so this high voltage
may have done somthn to video circuits,,,or it have has changed the option codes
due to the sparking,,,,just give me sometimes to check the service modes & will let you know to check somthn in service modes,,,,are you able to find a service remote control from your local LG service center ??

I do not know of any LG service center locally, i think though they would not let me have a service remote and my be a bit expensive but i will check.

I think if possible i look for a LG the same as mine with only the converge problem and swop some parts repairing one from two

can you tell me which board is the video board and which part of it is likely to be the problem. maybe i can see fault ?

thanks for all your help

Larry Dillon
Larry Dillon's picture
I do not think those are 47K

I do not think those are 47K resistors, I think they are 3.9 ohm. I know they are a lower value. where did you come up with 47k? what do the rest of them look like? colors like in the picture I see the first band is orange?

dayawansha
dayawansha's picture
please send the 'location

please send the 'location numbers' of those burned/darkened resistors...

rich321
rich321's picture
DJnupi said:

DJnupi said:

rich321 said: I have a convergence with my LG RE-39NZ43RB the green would drop from the centre top down below the bottom of the screen after reading all other related convergence problem I have checked both sets of the three resistors 47 K OHMS; 0.125 W; 5% all in range and replaced both convergence CI (STK392-120) (Sanyo) and now I still have a convergence problem but it has change as the green now drops from the centre top down as before but the centre bottom now goes up instead of down making the very centre of the screen perfect I have tried to auto converge, is it possible to do a manual converge ? changing both convergence CI (STK392-120) has altered convergence problem but not cure it please help any ideas welcome

finaly the stk-s arrived in my mailbox, and i bought 2 resistors that were visually burned (darkened)
so first i cut those resistors out and soldered them loose

then it was time to get the ic-s out, i used solder wick (copper wire) to suck up the solder to get the tiny legs loose. also unscrew the is-s from the aluminum cooler.

then it was time to place the new ics. use a medium amount of heat-conductin-paste

then carefully place the pins in the right holes  and fasten it with the screws

now solder it

ok, put the board back in the tv, tv on, try to converge, the problem just changed, no good converge. in the middle though i got it ok.

 i also cleaned the lenses (should have kept my hands off?), thought i did some permanent damage there. then, after 20 min. trying, the image changed for a second to something better, than back again. for me this was a sign it is something electical. take the board back out.
now, resoldered the ics, no change 

 the yellow is more n effect my digital camera did.
what to do now?
i think the cheapest route is just to change all resistors, just to be sure?
help? 

the resistors pictured may be the same i changed check picture november 17th 12:30pm which i later discoverd to be 3.9 ohm 2 watt metal film resisors check post november 19th - 30th3:22pm after changing them all was ok check with online resistor values chart but it may be difficult as they may have darkend

Larry Dillon
Larry Dillon's picture
glad to see the luck you had.

glad to see the luck you had. why dont you assemble an article and write about your troubles and how to avoid it with pictures then submit to the site? That would be a great thing if you could take the time to do it.

dayawansha
dayawansha's picture
djnupi,,,

djnupi,,,
takecare u have tapped the power supply for the STK ICs,,are you living in a area having very hot weather???otherwise dont worry much about STKs gettn hot,,,
its very normal to STKs to get hot,,,,these voltages you have tapped coming from the SMPS,,,those fans may require higher ampere to operate,,,,anyhow if your picture looks ok...leave it like that,,,applying the heat sink paste with the heatsink & on the IC slightly is very important for the heat transfer from the IC to the aluminium heat sink.......thanks,,daya.

daveh56
daveh56's picture
Hello

Hello

Convergence IC failures:

#1 Heat (that's why there is a big heatsink there the heat has to go somewhere)
#2 Convergence control circuit failure or data corruption in convergence memory
#3 Cold solder joints (wave soldering does not make for good connections to IC because of inadequate amount of solder) Hitachi's are famous for this

STK392-120 NEVER USE SUBSTITUTE! in Magnavox TV's (Hitachi OK)
Hitachi Says use STK394-160 for STK392-110 to 150's Hitachi will not supply the original STK's

Also there is a slight difference in the STK394-160 compared to STK392-110 150's besides running cooler etc it has to do with the convergence mute circuit. I don't know more then that have not been able to get a spec sheet for STK394-160 I think it is not there in the STK394-160 If someone knows more let me know

David Heller CET

TV tech since 1975

rich321
rich321's picture
rich321 said:

rich321 said:

dayawansha said: rich,,,its looks convergence ICs may got damagd again,,its before 5 months u have replacd both STKs no,,,anyhow 1 st now u have to follow why there is no video comn with the inputs,,,may be there is a connection with that cracking sound u heard before,,,it can be one of your CRT given high voltage leaking before,,,thts why you have heard a crackin sound i thnk,,,,so this high voltage may have done somthn to video circuits,,,or it have has changed the option codes due to the sparking,,,,just give me sometimes to check the service modes & will let you know to check somthn in service modes,,,,are you able to find a service remote control from your local LG service center ??

I do not know of any LG service center locally, i think though they would not let me have a service remote and my be a bit expensive but i will check.
I think if possible i look for a LG the same as mine with only the converge problem and swop some parts repairing one from two
can you tell me which board is the video board and which part of it is likely to be the problem. maybe i can see fault ?
thanks for all your help

Fixed my LG TV ,I bought a LG TV for spares which had a convergance problem and swapped the central main board(video/sound)? In to my TV my original convergance board with the new ICs I previously fitted which are still OK. Worked for me and loads of spares to save and play with, I think I will fit some new ICs to my spare convergance for a quick swap for if I have more convergance problems in the future and mybe a fan mod.

Thanks all

Larry Dillon
Larry Dillon's picture
Make sure you do not use

Make sure you do not use inexpensive or cheap STK IC's as all STK's are not alike!!!

dayawansha
dayawansha's picture
hey rich its great you have

hey rich its great you have fixed the tv...

ariana05
ariana05's picture
Hi have a problem with my lg

Hi have a problem with my lg rt 54na21t rear propjection tv , screen is curved at left top and bottom . the convergence arrow has moved from the centre to right of the screen . i have changed the two stk 392-120 ic but the problem remains . will anybody able to assist with this problem .

dayawansha
dayawansha's picture
ariana are you still havn the

ariana are you still havn the problm....?

ariana05
ariana05's picture
Yes i have replaced the two

Yes i have replaced the two stk 392-120 ic and the problem remain . the screen is curved on the left top and bottom of screen and the cross for convergence setting is of centre . Please assist .

dayawansha
dayawansha's picture
did u check forn the

did u check forn the resistors as DJnupi has said,,,,is there any burned resistors near the STKs..

ariana05
ariana05's picture
Yes i have tested all the

Yes i have tested all the resitors close to the stk and the same colours read the same values . is there a way of testing the stk or what else could be the problem .

ariana05
ariana05's picture
dayawansha said:

dayawansha said:
did u check forn the resistors as DJnupi has said,,,,is there any burned resistors near the STKs..

Hi my board is a mp 015 a . i have tested all teh resistors and the same colours give me the same reading s.

 

 

ariana05
ariana05's picture
DJnupi said:

DJnupi said:
Hi Ariana,
also check for burned resistors...
when an stk goes, some resistors go to.
the go in pairs, so check for 2 burned ones next to each other.
with my tv it was obvious, the stipes were burnt brown
(see photo, scroll upwards on this page, where i point them out with a screwdriver)

hi my board is a mp 015 a i have tested all teh resitors and the same colours give me the same values .

What else could teh problem be . i bought these ic for around 60 south african rands do you get then in different 

 

i have tested the resitor colour: green,blue,gold,gold some give me 2.5 and others 5,8 closer to stk .

 

ariana05
ariana05's picture
ariana05 said:

ariana05 said:

dayawansha said: did u check forn the resistors as DJnupi has said,,,,is there any burned resistors near the STKs..

Hi my board is a mp 015 a . i have tested all teh resistors and the same colours give me the same reading s.

Hi the resitors closer to the stk colour green ,blue ,gold,gold are reading 5,8 and the others further away are reading 2,5

 

dayawansha
dayawansha's picture
arian,,,,,finally whats

arian,,,,,finally whats happenning with your tv ????

ariana05
ariana05's picture
hi do you think that the stk

hi do you think that the stk could be faulty or is it the convergence module.
i have been checking around and the stk that i have were purchased for around 60 south african rands that about 7 dollars and there is a conpany that has the stk for around 30 dollars which is around 230 south african rands .

please advise if i should replace the stk or is it the convergence module

dayawansha
dayawansha's picture
arian,,as i have said befo

arian,,as i have said befo make sure whether the -26 & +26 volts are coming to the STK board,,are these 2 voltages coming?? did you check that..?

Larry Dillon
Larry Dillon's picture
Does anyone have a service

Does anyone have a service manual/schematic for the LG sets??
Larry Dillon

ariana05
ariana05's picture
Hi i need assistance , having

Hi i need assistance , having a convergence fault on my rt 54 rear projection tv ,picture is curved on the left bottom and top , colour is all messed up and picture looks 3d , chanked the two stk ic and tested all resistors on the board. can you please help with a procedure to test the + and - voltages on the convergence board and also what else i can look for . I used a hot air station to replace the stk -will heat affect them .

Pages

 

Connect With Techlore