Mitsubishi WS-65711 HDTV Green Blinking Light

1107 posts / 0 new
Last post
jj
jj's picture
Hi Larry,

Hi Larry,

You are obviously too kind and have many requests.  My green light is also blinking.  Would you be so kind as to send me the instructions as well.  Thanks, Michael 

moymaian@flash.net

jj
jj's picture
Hi Larry,

Hi Larry,

You are obviously too kind and have many requests.  My green light is also blinking.  Would you be so kind as to send me the instructions as well.  Model#: 55813    Thanks, Michael 

moymaian@flash.net

Larry Dillon
Larry Dillon's picture
sleeper do you see the model

sleeper do you see the model number in the thread is? NO where near the model you have and this really throws off the whole thing when you all post the wrong model number. I will try to set up a separate thread for you man. I like to send out bulk type mailings to those who all have the same modle groups. I will set you up, you should do the same. Hang tight I will get this to you. IF you tell me where to send this!?

Larry Dillon
Larry Dillon's picture
moy, I am sending it out

moy, I am sending it out sometime this evening.

wormy
wormy's picture
Hi Larry

Hi Larry

Sorry about posting to wrong thread. I'm new to the site. I appreciate any help you can offer.

Thank You

mharlacher@mac.com

LUKIN1
LUKIN1's picture
Hi Larry,

Hi Larry,

I also have the 'blinking light of death'.  The light on my WS-55813 began blinking 3 days ago and I have had no luck resetting.  I hate to ask, but if your still sending out bulk mailings of your repair documents can you add me to your list?  My address is bondrovik@hotmail.com  Thanks for all of your comments on this thread -  it's nice to have an option that won't cost $1000.00.

Thanks,

Brian

Curt1950
Curt1950's picture
Great site .. wish I had

Great site .. wish I had found it earlier .. but then I may be a bit lazy .. lol

my problem on my WS 55511 2002 model .. was that it turned on, and in 3 seconds light turned off, no pic ever appeared .. turned out to be the IC plus 2 related pico fuses ....  was a bit of a job gettin' to the IC / removing board / HIGHLY recommend a cordless screwdriver  .. the IC was so bad that when tech de soldered it, legs fell out of the IC ...  and it was certainly in need of alot of heat sink compound .. one thing Mitshibusi didn't use nearly enough of ...  n e way .. cost me 350 total .. would of been nice to do it myself, but not complaining -- as long as you have the back off, don't forget to grab a soft cloth and wipe the dust off your lenses ....  WOW .. picture quality improved 100 % .... lol

silverbob
silverbob's picture
 Well I did replace my 4

 Well I did replace my 4 Capacitors on my 65" Mitsubishi ....and now works great.

I will say i got my friend who does soldering to do the soldering part. After i put it back together it didnt work. Somake sure capacitors are pressed down fimly seated to board, that was my prob.

Son as i pressed then down and put it all back together voila......Back to new!!!

jsnlee
jsnlee's picture
I do not have the blinking

I do not have the blinking light problem.  However, I do believe I have a capacitor problem becuase sparks are coming out of it.  Model = ws-55805.  Do you think your documentation could help?  Thanks in advance.  jsnlee@charter.net

Ed100
Ed100's picture
Larry,

Larry,

I too have the dreaded green light problem on a Mit. 55613.  Ia am good with electronics, soldering and minor troubleshooting.  Would appreciate if you sent me the file at:

tim@kalmot.com

Thanks in advance.

also copy:

tkaley@ectisp.net

in case my work firewall stops the email.

Larry Dillon
Larry Dillon's picture
Tim, I will be more then

Tim, I will be more then happy to send them your way tonight. Good luck!

docpaul1
docpaul1's picture
Another blinking green light

Another blinking green light after the power went out problem! I have the Mitsubishi WS-65513. I would like to try and replace the capacitors on the board myself. Is it possible for you to email me the directions? I would greatly appreciate it. Thanks

By the way, what a great website. I wish I had found it sooner!

garthed
garthed's picture
Larry I am also having the

Larry I am also having the green blinking light problem. Could you also email me the instruction on the fix. I have a ws65869. My email is garthed@sbcglobal.net

Thanks

Garth

damien1115
damien1115's picture
Larry,

Larry,

 Could you please send me the doc as well...you are truly a life saver!!!!

damien1115@msn.com

Thanks!

robkorzuch
robkorzuch's picture
Larry, I am also having the

Larry, I am also having the problem with the blinking light on a WS-65711.  Could you please email me your resolution as well.  My email address is: rkorzuch@hotmail.com.  Thanks!

Larry Dillon
Larry Dillon's picture
rob and damien, that info

rob and damien, that info will go out to you in just a little while. Good Luck

docpaul1
docpaul1's picture
Could you please send the fix

Could you please send the fix instructions for the blinking light of death problem on the mitsubishi WS-65513. my email is docpaul1@comcast.net. Thanks for your help

Larry Dillon
Larry Dillon's picture
docpaul, they are on their

docpaul, they are on their way. Good Luck with the repair.

luigino
luigino's picture
I'm having the same blinking

I'm having the same blinking green problem with my Mitsu 65" rear projection can you please email the fix docs? luigino916@yahoo.com .  Thanks in advance. Lou

t allen
t allen's picture
my tv model ws65611 is having

my tv model ws65611 is having the same green light issue as everyone else. can you please send me the repair files. my email is deuce32@iquest.net thank you very much.

Larry Dillon
Larry Dillon's picture
Sure t allen, I will have

Sure t allen, I will have them out to you shortly. Good Luck

luigino
luigino's picture
Larry Dillon said: luigino,

Larry Dillon said: luigino, what is the model number man?

WS-65713.  thanks for responding

Larry Dillon
Larry Dillon's picture
luigino, They are on there

luigino, They are on there way. Good Luck

woodsgirls
woodsgirls's picture
Hi Larry,

Hi Larry,

Same problem with the little green flashing light.  Would you please send me the information, too.  My model is WS-55513.

Thanks so much!!!  Michelle

woodsgirls@sbcglobal.net 

wrath
wrath's picture
It seems alot of us have the

It seems alot of us have the blinking green light of death on our tv's. Could you please forward the file, I am not saavy when it comes to this fix it stuff, but I am sure I have a friend who can help. My model is a WS-55859.

tphillips1@cox.net

Thank you so much, Tim

luigino
luigino's picture
Larry Dillon said: luigino,

Larry Dillon said: luigino, They are on there way. Good Luck

Youre the best. Thanks.

cgsheen
cgsheen's picture
Larry,

Larry,

 I can't believe I found this thread!  Our WS-55813 just acquired "the blinking green light of death" yesterday morning.  I've got the Service Manual and even took it apart yesterday to see if there was something really obvious.

Would you please add me to the list for the fix?

Thanks so much!

Edit:

Our 55813 lives again!  As soon as I finished scanning this thread, I grabbed the SM and read up on how to remove the DM (the only board I hadn't checked because it was covered by the metal shield).  Once I had it out it was obvious!  We have a Fry's Electronics nearby and they stock the standard CAPs.  About 15 minutes of de-soldering & soldering in the new CAPs and she was ready to put back together.  Fired right back up...  Eight bucks worth of parts - unbelievable!  Makes sense, I've lost a few PC motherboards to blown CAPs...

Larry Dillon
Larry Dillon's picture
Great News! I am glad you

Great News! I am glad you found us. Don't forget to look at the service manual and see how the front screen comes off so you can clean the mirrors and lens. This will brighten and clear up the picture. Many times to brand new condition.

cgsheen
cgsheen's picture
Thanks!  I did that on Friday

Thanks!  I did that on Friday when I first tinkered with the set.  I took the front screen off (actually all the front and rear panels), cleaned the mirror and the lenses, got the dust out of the whole thing.  It was actually cleaner than I expected for a nearly 5 year old set.  My wife is estatic!  (it's "her" TV...)  She thinks the picture is better than ever and she's amazed we didn't have to send it out to a shop.

The repair even cleared up a little "noise" we were getting.  For the last couple of months there's been a faint set of "static-y lines" kind of scrolling down through the picture.  Totally gone now.  Picture is clear as a bell.

wrath
wrath's picture
Hi Larry,

Hi Larry,

have not seen your reply yet for my ws-55859 , could you please forward me the fix everyone is talking about with the flashing green light of death.

Thanks in advance

Tim

tphillips1@cox.net

Pages

Topic locked
 

Connect With Techlore